Browse Source

Add uinput-permfix

master
Dejvino 3 years ago
parent
commit
1095b3cfaf
4 changed files with 55 additions and 0 deletions
  1. +38
    -0
      repo/dejvino/uinput-permfix/PKGBUILD
  2. +5
    -0
      repo/dejvino/uinput-permfix/uinput-permfix
  3. +5
    -0
      repo/dejvino/uinput-permfix/uinput-permfix.service
  4. +7
    -0
      repo/dejvino/uinput-permfix/uinput-permfix.timer

+ 38
- 0
repo/dejvino/uinput-permfix/PKGBUILD View File

@@ -0,0 +1,38 @@
_pkgbase=uinput-permfix
pkgname=uinput-permfix
pkgver=1
pkgrel=1
pkgdesc="/dev/uinput permissions fix: set owner to 'input' group"
url=""
arch=('any')
license=('GPL')
depends=()
makedepends=()
source=(
uinput-permfix.service
uinput-permfix.timer
uinput-permfix
)
sha256sums=(
ea5a029fe085ed201e7e8015198fd0b27c71808e7ee3640b13552c3d9a20842e
2acdfc8d85c1c57557127b856b069c02aafe2b8793a644ab1fc241a8a92fb084
b7c3c491689f10a99e882dfd7206ea91406b196e431dca447ebb088e094cbcfc
)

package() {
install -D -m644 "$srcdir"/uinput-permfix.service \
"$pkgdir"/etc/systemd/system/uinput-permfix.service
install -D -m644 "$srcdir"/uinput-permfix.timer \
"$pkgdir"/etc/systemd/system/uinput-permfix.timer
install -D -m755 "$srcdir"/uinput-permfix \
"$pkgdir"/usr/local/sbin/uinput-permfix
}

post_install() {
systemctl enable --now uinput-permfix.timer
}

pre_remove() {
systemctl disable uinput-permfix.timer
}


+ 5
- 0
repo/dejvino/uinput-permfix/uinput-permfix View File

@@ -0,0 +1,5 @@
#!/bin/bash

chown root:input /dev/uinput
chmod g+rw /dev/uinput


+ 5
- 0
repo/dejvino/uinput-permfix/uinput-permfix.service View File

@@ -0,0 +1,5 @@
[Unit]
Description=UInput Permfix
[Service]
Type=oneshot
ExecStart=/usr/local/sbin/uinput-permfix

+ 7
- 0
repo/dejvino/uinput-permfix/uinput-permfix.timer View File

@@ -0,0 +1,7 @@
[Unit]
Description=UInput Permfix
[Timer]
OnBootSec=1min
OnUnitActiveSec=2min
[Install]
WantedBy=timers.target

Loading…
Cancel
Save